Search docs/

サポートポリシー

コミュニティメンテナンス

Ionic Frameworkは当初から100%オープンソース(MIT)で、今後もオープンソースとして公開されます。開発者は、Ionicのコミュニティメンテナンス戦略を通して、Ionicが彼らのクロスプラットフォームアプリにとって正しい選択であることを保証することができます。Ionicチームは定期的に新しいリリースとバグ修正を提供しており、コミュニティからのプルリクエストを歓迎しています。

Framework Maintenance and Support Status

Given the reality of time and resource restraints as well as the desire to keep innovating in the frontend development space, over time it becomes necessary for the Ionic team to shift focus to newer versions of the Framework. However, Ionic will do everything it can to make the transition to newer versions as smooth as possible. The Ionic team recommends updating to the newest version of the Ionic Framework for the latest features, improvements and stability updates. For more details, consult the Migration page.

The current status of each Ionic Framework version is:

Version Status Released Maintenance Ends Ext. Support Ends
V5 Active Feb 11, 2020 TBD TBD
V4 Maintenance Jan 23, 2019 Aug 11, 2020 TBD
V3 Extended Support Only Apr 5, 2017 Oct 30, 2019 Aug 11, 2020
V2 End of Support Jan 25, 2017 Apr 5, 2017 Apr 5, 2017
V1 End of Support May 12, 2015 Jan 25, 2017 Jan 25, 2017
  • Maintenance: Only critical bug and security fixes. No major feature improvements.
  • Extended Support: For teams and organizations that require additional long term support, Ionic has extended support options available. To learn more, see our Enterprise offerings.

Compatibility Recommendations

The Ionic team has compiled a set of recommendations for using the Ionic Framework in conjunction with other contextually-relevant software. This is not meant to be a comprehensive list, but covers many common compatibility questions. The Ionic team strongly recommends reviewing your project dependencies once each quarter to keep track of new releases, features and bug fixes.

Core Dependencies

Framework Angular React Typescript
V5 - Angular v8.2.X N/A 3.5.X
V5 - React N/A 16.8.X 3.7.X
V4 - Angular v8.2.X N/A 3.5.X
V4 - React N/A 16.8.X 3.7.X
V3 v5.2.11 Not supported 2.6.2
  • The Ionic team generally recommends the latest releases of third party packages and strives to support the latest releases within 2-4 weeks of general availability.

Native Bridges

Framework Cordova Capacitor
V5 - Angular cordova-android 8.X, cordova-ios 5.X Latest 2.X
V5 - React Not supported Latest 2.x
V4 - Angular cordova-android 8.X, cordova-ios 5.X Latest 2.X
V4 - React Not supported Latest 2.x
V3 cordova-android 8.X, cordova-ios 5.X Not officially supported
  • As iOS and Android (and related tools) are updated, you can expect more updates for Cordova and Capacitor, so it is recommended to stay on the latest version(s) of Cordova and Capacitor.

Ionic Platform & Products

Framework Ionic Appflow Ionic Native Premier Plugins*
V5 - Angular @ionic/angular 5.X Use latest available
V5 - React @ionic/react 5.X Use latest available
V4 - Angular @ionic/angular 4.X Use latest available
V4 - React @ionic/react 4.X Use latest available
V3 ionic-angular 3.9.X Use latest; special configuration may be required

Ionic Platform & Products (Cont.)

Framework Ionic Studio Ionic Native Community Plugins*
V5 - Angular @ionic/angular 5.X @ionic-native 5.X
V5 - React Not currently supported @ionic-native 5.X*
V4 - Angular @ionic/angular 5.X @ionic-native 5.X
V4 - React Not currently supported @ionic-native 5.X*
V3 Not currently supported @ionic-native 4.X
  • Wrappers (and their associated plugins) are community maintained.
  • *Cordova plugin support with Ionic Native and @ionic/react can be achieved using the vanilla JavaScript implementation
Previous
Release Notes
Next
Browser Support